Cross-site Scripting (XSS)

Affecting mediawiki package, versions <1:1.27.7-1~deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mediawiki package. See Remediation section below for Debian:9 relevant versions.

Wikimedia MediaWiki 1.30.0 through 1.32.1 has XSS. Loading user JavaScript from a non-existent account allows anyone to create the account, and perform XSS on users loading that script. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Remediation

Upgrade Debian:9 mediawiki to version 1:1.27.7-1~deb9u1 or higher.

References

CVSS Score

6.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE
CVE-2019-12471
CWE
CWE-79
Snyk ID
SNYK-DEBIAN9-MEDIAWIKI-349096
Disclosed
10 Jul, 2019
Published
09 Jun, 2019