Cross-site Scripting (XSS)

Affecting mediawiki package, versions <0.0.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). An issue was discovered in MediaWiki before 1.31.12 and 1.32.x through 1.35.x before 1.35.2. On ChangesList special pages such as Special:RecentChanges and Special:Watchlist, some of the rcfilters-filter-* label messages are output in HTML unescaped, leading to XSS.

Remediation

Upgrade mediawiki to version 0 or higher.

References

CVSS Score

6.1
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE
CVE-2021-30157
CWE
CWE-79
Snyk ID
SNYK-DEBIAN9-MEDIAWIKI-1243870
Disclosed
06 Apr, 2021
Published
07 Apr, 2021