Information Exposure

Affecting mediawiki package, versions <1:1.27.7-1~deb9u7

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mediawiki package. See Remediation section below for Debian:9 relevant versions.

An issue was discovered in MediaWiki before 1.35.1. Missing users (accounts that don't exist) and hidden users (accounts that have been explicitly hidden due to being abusive, or similar) that the viewer cannot see are handled differently, exposing sensitive information about the hidden status to unprivileged viewers. This exists on various code paths.

Remediation

Upgrade Debian:9 mediawiki to version 1:1.27.7-1~deb9u7 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
CVE
CVE-2020-35480
CWE
CWE-200
Snyk ID
SNYK-DEBIAN9-MEDIAWIKI-1052815
Disclosed
18 Dec, 2020
Published
18 Dec, 2020