OS Command Injection

Affecting mariadb-10.1 package, versions <10.1.48-0+deb9u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mariadb-10.1 package. See Remediation section below for Debian:9 relevant versions.

A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.

Remediation

Upgrade Debian:9 mariadb-10.1 to version 10.1.48-0+deb9u2 or higher.

References

CVSS Score

7.2
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:F
CVE
CVE-2021-27928
CWE
CWE-78
Snyk ID
SNYK-DEBIAN9-MARIADB101-1087460
Disclosed
19 Mar, 2021
Published
19 Mar, 2021