Improper Restriction of Recursive Entity References in DTDs ('XML Entity Expansion')

Affecting libxml2 package, versions <2.9.4+dfsg1-2.2+deb9u5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:9 relevant versions.

A flaw was found in libxml2. Exponential entity expansion attack its possible bypassing all existing protection mechanisms and leading to denial of service.

Remediation

Upgrade Debian:9 libxml2 to version 2.9.4+dfsg1-2.2+deb9u5 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2021-3541
CWE
CWE-776
Snyk ID
SNYK-DEBIAN9-LIBXML2-1293203
Disclosed
09 Jul, 2021
Published
16 May, 2021