Use After Free

Affecting libxml2 package, versions <2.9.4+dfsg1-2.2+deb9u4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream libxml2 package. See Remediation section below for Debian:9 relevant versions.

There's a flaw in libxml2 in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by an application linked with libxml2 could trigger a use-after-free. The greatest impact from this flaw is to confidentiality, integrity, and availability.

Remediation

Upgrade Debian:9 libxml2 to version 2.9.4+dfsg1-2.2+deb9u4 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2021-3518
CWE
CWE-416
Snyk ID
SNYK-DEBIAN9-LIBXML2-1277342
Disclosed
18 May, 2021
Published
28 Apr, 2021