Out-of-bounds Read

Affecting libsoup2.4 package, versions <2.56.0-2+deb9u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

The get_cookies function in soup-cookie-jar.c in libsoup 2.63.2 allows attackers to have unspecified impact via an empty hostname.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2018-12910
CWE
CWE-125
Snyk ID
SNYK-DEBIAN9-LIBSOUP24-272294
Disclosed
05 Jul, 2018
Published
11 Jul, 2018