Cross-site Scripting (XSS)

Affecting jquery package, versions <3.1.1-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream jquery package. See Remediation section below for Debian:9 relevant versions.

jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.

Remediation

Upgrade Debian:9 jquery to version 3.1.1-1 or higher.

References

CVSS Score

6.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE
CVE-2015-9251
CWE
CWE-79
Snyk ID
SNYK-DEBIAN9-JQUERY-290109
Disclosed
18 Jan, 2018
Published
18 Jan, 2018