Out-of-Bounds

Affecting file package, versions <1:5.17-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream file package. See Remediation section below for Debian:9 relevant versions.

softmagic.c in file before 5.17 and libmagic allows context-dependent attackers to cause a denial of service (out-of-bounds memory access and crash) via crafted offsets in the softmagic of a PE executable.

Remediation

Upgrade Debian:9 file to version 1:5.17-1 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
CVE
CVE-2014-2270
CWE
CWE-119
Snyk ID
SNYK-DEBIAN9-FILE-300948
Disclosed
14 Mar, 2014
Published
14 Mar, 2014