Uncontrolled Recursion

Affecting djvulibre package, versions <3.5.27.1-7+deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream djvulibre package. See Remediation section below for Debian:9 relevant versions.

In DjVuLibre 3.5.27, the sorting functionality (aka GArrayTemplate<TYPE>::sort) allows attackers to cause a denial-of-service (application crash due to an Uncontrolled Recursion) by crafting a PBM image file that is mishandled in libdjvu/GContainer.h.

Remediation

Upgrade Debian:9 djvulibre to version 3.5.27.1-7+deb9u1 or higher.

References

CVSS Score

5.5
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2019-15144
CWE
CWE-674
Snyk ID
SNYK-DEBIAN9-DJVULIBRE-459732
Disclosed
18 Aug, 2019
Published
18 Aug, 2019