Cross-site Scripting (XSS)

Affecting cups package, versions <1.7.5-12

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package. See Remediation section below for Debian:9 relevant versions.

Cross-site scripting (XSS) vulnerability in the cgi_puts function in cgi-bin/template.c in the template engine in CUPS before 2.0.3 allows remote attackers to inject arbitrary web script or HTML via the QUERY parameter to help/.

Remediation

Upgrade Debian:9 cups to version 1.7.5-12 or higher.

References

CVSS Score

4.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N/E:F
CVE
CVE-2015-1159
CWE
CWE-79
Snyk ID
SNYK-DEBIAN9-CUPS-364372
Disclosed
26 Jun, 2015
Published
26 Jun, 2015