Arbitrary Command Injection

Affecting bzr package, versions <2.7.0+bzr6619-7+deb9u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Bazaar through 2.7.0, when Subprocess SSH is used, allows remote attackers to execute arbitrary commands via a bzr+ssh URL with an initial dash character in the hostname, a related issue to CVE-2017-9800, CVE-2017-12836, CVE-2017-12976, CVE-2017-16228, CVE-2017-1000116, and CVE-2017-1000117.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2017-14176
Snyk ID
SNYK-DEBIAN9-BZR-269928
Disclosed
27 Nov, 2017
Published
27 Nov, 2017