Information Exposure

Affecting apt package, versions <0.9.7.7

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream apt package. See Remediation section below for Debian:9 relevant versions.

Apt 0.8.16exp5ubuntu13.x before 0.8.16exp5ubuntu13.6, 0.8.16exp12ubuntu10.x before 0.8.16exp12ubuntu10.7, and 0.9.7.5ubuntu5.x before 0.9.7.5ubuntu5.2, as used in Ubuntu, uses world-readable permissions for /var/log/apt/term.log, which allows local users to obtain sensitive shell information by reading the log file.

Remediation

Upgrade Debian:9 apt to version 0.9.7.7 or higher.

References

CVSS Score

4.0
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
CVE
CVE-2012-0961
CWE
CWE-200
Snyk ID
SNYK-DEBIAN9-APT-407457
Disclosed
26 Dec, 2012
Published
26 Dec, 2012