Link Following

Affecting mercurial package, versions <3.1.2-2+deb8u7

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mercurial package. See Remediation section below for Debian:8 relevant versions.

A flaw was found in Mercurial before 4.9. It was possible to use symlinks and subrepositories to defeat Mercurial's path-checking logic and write files outside a repository.

Remediation

Upgrade Debian:8 mercurial to version 3.1.2-2+deb8u7 or higher.

References

CVSS Score

5.9
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
CVE
CVE-2019-3902
CWE
CWE-22 CWE-59
Snyk ID
SNYK-DEBIAN8-MERCURIAL-344204
Disclosed
22 Apr, 2019
Published
20 Apr, 2019