Improper Certificate Validation

Affecting mercurial package, versions <1.6.4-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mercurial package. See Remediation section below for Debian:8 relevant versions.

Mercurial before 1.6.4 fails to verify the Common Name field of SSL certificates which allows remote attackers who acquire a certificate signed by a Certificate Authority to perform a man-in-the-middle attack.

Remediation

Upgrade Debian:8 mercurial to version 1.6.4-1 or higher.

References

CVSS Score

5.9
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
CVE
CVE-2010-4237
CWE
CWE-295
Snyk ID
SNYK-DEBIAN8-MERCURIAL-311147
Disclosed
29 Oct, 2019
Published
27 Jun, 2018