Improper Input Validation

Affecting mercurial package, versions <3.1.2-2+deb8u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mercurial package. See Remediation section below for Debian:8 relevant versions.

Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted git ext:: URL when cloning a subrepository.

Remediation

Upgrade Debian:8 mercurial to version 3.1.2-2+deb8u2 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2016-3068
CWE
CWE-20
Snyk ID
SNYK-DEBIAN8-MERCURIAL-311142
Disclosed
13 Apr, 2016
Published
13 Apr, 2016