Improper Input Validation

Affecting mercurial package, versions <3.1.2-2+deb8u5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

The mpatch_apply function in mpatch.c in Mercurial before 4.6.1 incorrectly proceeds in cases where the fragment start is past the end of the original data, aka OVE-20180430-0004.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVE
CVE-2018-13346
CWE
CWE-20
Snyk ID
SNYK-DEBIAN8-MERCURIAL-311086
Disclosed
06 Jul, 2018
Published
11 Jul, 2018