Improper Input Validation

Affecting mercurial package, versions <3.1.2-2+deb8u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream mercurial package. See Remediation section below for Debian:8 relevant versions.

The _validaterepo function in sshpeer in Mercurial before 3.2.4 allows remote attackers to execute arbitrary commands via a crafted repository name in a clone command.

Remediation

Upgrade Debian:8 mercurial to version 3.1.2-2+deb8u1 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVE
CVE-2014-9462
CWE
CWE-20
Snyk ID
SNYK-DEBIAN8-MERCURIAL-311054
Disclosed
31 Mar, 2015
Published
31 Mar, 2015