Out-of-bounds Read

Affecting libxml2 package, versions <2.9.1+dfsg1-5+deb8u5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer over-read in the xmlDictAddString function in dict.c. This vulnerability causes programs that use libxml2, such as PHP, to crash. This vulnerability exists because of an incomplete fix for CVE-2016-1839.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2017-9050
CWE
CWE-125
Snyk ID
SNYK-DEBIAN8-LIBXML2-429285
Disclosed
18 May, 2017
Published
18 May, 2017