Out-of-Bounds

Affecting libtasn1-6 package, versions <4.2-3+deb8u3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Two errors in the "asn1_find_node()" function (lib/parser_aux.c) within GnuTLS libtasn1 version 4.10 can be exploited to cause a stacked-based buffer overflow by tricking a user into processing a specially crafted assignments file via the e.g. asn1Coding utility.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2017-6891
CWE
CWE-119
Snyk ID
SNYK-DEBIAN8-LIBTASN16-339575
Disclosed
22 May, 2017
Published
22 May, 2017