Out-of-Bounds

Affecting glibc package, versions <2.19-18+deb8u10

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

glibc contains a vulnerability that allows specially crafted LD_LIBRARY_PATH values to manipulate the heap/stack, causing them to alias, potentially resulting in arbitrary code execution. Please note that additional hardening changes have been made to glibc to prevent manipulation of stack and heap memory but these issues are not directly exploitable, as such they have not been given a CVE. This affects glibc 2.25 and earlier.

References

CVSS Score

7.8
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2017-1000366
CWE
CWE-119
Snyk ID
SNYK-DEBIAN8-GLIBC-356540
Disclosed
19 Jun, 2017
Published
19 Jun, 2017