Improper Input Validation

Affecting cups package, versions <1.7.5-11+deb8u3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package. See Remediation section below for Debian:8 relevant versions.

The add_job function in scheduler/ipp.c in CUPS before 2.2.6, when D-Bus support is enabled, can be crashed by remote attackers by sending print jobs with an invalid username, related to a D-Bus notification.

Remediation

Upgrade Debian:8 cups to version 1.7.5-11+deb8u3 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2017-18248
CWE
CWE-20
Snyk ID
SNYK-DEBIAN8-CUPS-364434
Disclosed
26 Mar, 2018
Published
26 Mar, 2018