Link Following

Affecting cups package, versions <1.7.4-2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package. See Remediation section below for Debian:8 relevant versions.

CUPS before 2.0 allows local users to read arbitrary files via a symlink attack on (1) index.html, (2) index.class, (3) index.pl, (4) index.php, (5) index.pyc, or (6) index.py.

Remediation

Upgrade Debian:8 cups to version 1.7.4-2 or higher.

References

CVSS Score

3.3
low severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
CVE
CVE-2014-5030
CWE
CWE-59
Snyk ID
SNYK-DEBIAN8-CUPS-364344
Disclosed
29 Jul, 2014
Published
29 Jul, 2014