Incorrect Authorization

Affecting xorg-server package, versions <2:1.20.3-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream xorg-server package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in xorg-x11-server before 1.20.3. An incorrect permission check for -modulepath and -logfile options when starting Xorg. X server allows unprivileged users with the ability to log in to the system via physical console to escalate their privileges and run arbitrary code under root privileges.

Remediation

Upgrade Debian:10 xorg-server to version 2:1.20.3-1 or higher.

References

CVSS Score

6.6
medium severity
  • Attack Vector
    Physical
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:P/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:F
CVE
CVE-2018-14665
CWE
CWE-863
Snyk ID
SNYK-DEBIAN10-XORGSERVER-327205
Disclosed
25 Oct, 2018
Published
28 Oct, 2018