Improper Input Validation

Affecting xorg-server package, versions <2:1.19.5-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream xorg-server package. See Remediation section below for Debian:10 relevant versions.

xorg-x11-server before 1.19.5 was missing length validation in XFree86 DGA extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.

Remediation

Upgrade Debian:10 xorg-server to version 2:1.19.5-1 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2017-12181
CWE
CWE-20
Snyk ID
SNYK-DEBIAN10-XORGSERVER-326995
Disclosed
24 Jan, 2018
Published
24 Jan, 2018