Cryptographic Issues

Affecting unbound package, versions <1.3.4-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream unbound package. See Remediation section below for Debian:10 relevant versions.

Unbound before 1.3.4 does not properly verify signatures for NSEC3 records, which allows remote attackers to cause secure delegations to be downgraded via DNS spoofing or other DNS-related attacks in conjunction with crafted delegation responses.

Remediation

Upgrade Debian:10 unbound to version 1.3.4-1 or higher.

References

CVSS Score

7.3
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVE
CVE-2009-3602
CWE
CWE-310
Snyk ID
SNYK-DEBIAN10-UNBOUND-320312
Disclosed
13 Oct, 2009
Published
13 Oct, 2009