Improper Input Validation

Affecting unbound package, versions <1.7.1-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream unbound package. See Remediation section below for Debian:10 relevant versions.

A flaw was found in the way unbound before 1.6.8 validated wildcard-synthesized NSEC records. An improperly validated wildcard NSEC record could be used to prove the non-existence (NXDOMAIN answer) of an existing wildcard record, or trick unbound into accepting a NODATA proof.

Remediation

Upgrade Debian:10 unbound to version 1.7.1-1 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
CVE
CVE-2017-15105
CWE
CWE-20 CWE-358
Snyk ID
SNYK-DEBIAN10-UNBOUND-320273
Disclosed
23 Jan, 2018
Published
23 Jan, 2018