Out-of-bounds Write

Affecting openexr package, versions <2.2.1-4.1+deb10u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream openexr package. See Remediation section below for Debian:10 relevant versions.

makeMultiView.cpp in exrmultiview in OpenEXR 2.3.0 has an out-of-bounds write, leading to an assertion failure or possibly unspecified other impact.

Remediation

Upgrade Debian:10 openexr to version 2.2.1-4.1+deb10u1 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2018-18444
CWE
CWE-787
Snyk ID
SNYK-DEBIAN10-OPENEXR-331172
Disclosed
17 Oct, 2018
Published
17 Oct, 2018