Improper Input Validation

Affecting node-lodash package, versions <4.17.11+dfsg-2+deb10u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream node-lodash package. See Remediation section below for Debian:10 relevant versions.

Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.

Remediation

Upgrade Debian:10 node-lodash to version 4.17.11+dfsg-2+deb10u1 or higher.

References

CVSS Score

9.1
critical severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
CVE
CVE-2019-10744
Snyk ID
SNYK-DEBIAN10-NODELODASH-455505
Disclosed
26 Jul, 2019
Published
26 Jul, 2019