Improper Input Validation

Affecting nginx package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

nginx 0.7.64 writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.

References

CVSS Score

6.3
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
CVE
CVE-2009-4487
Snyk ID
SNYK-DEBIAN10-NGINX-341071
Disclosed
13 Jan, 2010
Published
13 Jan, 2010