Incorrect Default Permissions

Affecting libzstd package, versions <1.3.8+dfsg-3+deb10u2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Incorrect Default Permissions. Beginning in v1.4.1 and prior to v1.4.9, due to an incomplete fix for CVE-2021-24031, the Zstandard command-line utility created output files with default permissions and restricted those permissions immediately afterwards. Output files could therefore momentarily be readable or writable to unintended parties.

Remediation

Upgrade libzstd to version or higher.

References

CVSS Score

9.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CVE
CVE-2021-24032
CWE
CWE-276 CWE-277
Snyk ID
SNYK-DEBIAN10-LIBZSTD-1080899
Disclosed
04 Mar, 2021
Published
02 Mar, 2021