Improper Access Control

Affecting libxslt package, versions <1.1.32-2.1~deb10u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

libxslt through 1.1.33 allows bypass of a protection mechanism because callers of xsltCheckRead and xsltCheckWrite permit access even upon receiving a -1 error code. xsltCheckRead can return -1 for a crafted URL that is not actually invalid and is subsequently loaded.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2019-11068
CWE
CWE-284
Snyk ID
SNYK-DEBIAN10-LIBXSLT-343163
Disclosed
10 Apr, 2019
Published
10 Apr, 2019