Improper Input Validation

Affecting gnupg2 package, versions <2.0.24-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream gnupg2 package. See Remediation section below for Debian:10 relevant versions.

The do_uncompress function in g10/compress.c in GnuPG 1.x before 1.4.17 and 2.x before 2.0.24 allows context-dependent attackers to cause a denial of service (infinite loop) via malformed compressed packets, as demonstrated by an a3 01 5b ff byte sequence.

Remediation

Upgrade Debian:10 gnupg2 to version 2.0.24-1 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE
CVE-2014-4617
CWE
CWE-20
Snyk ID
SNYK-DEBIAN10-GNUPG2-340416
Disclosed
25 Jun, 2014
Published
25 Jun, 2014