Improper Input Validation

Affecting gnupg2 package, versions <2.0.22-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream gnupg2 package. See Remediation section below for Debian:10 relevant versions.

The compressed packet parser in GnuPG 1.4.x before 1.4.15 and 2.0.x before 2.0.22 allows remote attackers to cause a denial of service (infinite recursion) via a crafted OpenPGP message.

Remediation

Upgrade Debian:10 gnupg2 to version 2.0.22-1 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE
CVE-2013-4402
CWE
CWE-20
Snyk ID
SNYK-DEBIAN10-GNUPG2-340409
Disclosed
28 Oct, 2013
Published
28 Oct, 2013