Improper Input Validation

Affecting file package, versions <1:5.22+15-1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

readelf.c in file before 5.22, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not consider that pread calls sometimes read only a subset of the available data, which allows remote attackers to cause a denial of service (uninitialized memory access) or possibly have unspecified other impact via a crafted ELF file.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVE
CVE-2014-9653
CWE
CWE-20
Snyk ID
SNYK-DEBIAN10-FILE-301076
Disclosed
30 Mar, 2015
Published
30 Mar, 2015