Buffer Overflow

Affecting cups package, versions <2.2.10-6+deb10u1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package. See Remediation section below for Debian:10 relevant versions.

A buffer overflow issue was addressed with improved memory handling. This issue is fixed in macOS Mojave 10.14.6, Security Update 2019-004 High Sierra, Security Update 2019-004 Sierra. An attacker in a privileged network position may be able to execute arbitrary code.

Remediation

Upgrade Debian:10 cups to version 2.2.10-6+deb10u1 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2019-8696
CWE
CWE-120
Snyk ID
SNYK-DEBIAN10-CUPS-459681
Disclosed
27 Oct, 2020
Published
17 Aug, 2019