Out-of-Bounds

Affecting cups package, versions <1.5.0-16

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream cups package. See Remediation section below for Debian:10 relevant versions.

Heap-based buffer overflow in the pdftoopvp filter in CUPS and cups-filters before 1.0.47 allows remote attackers to execute arbitrary code via a crafted PDF file.

Remediation

Upgrade Debian:10 cups to version 1.5.0-16 or higher.

References

CVSS Score

6.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
CVE
CVE-2013-6474
CWE
CWE-119
Snyk ID
SNYK-DEBIAN10-CUPS-364486
Disclosed
14 Mar, 2014
Published
14 Mar, 2014