Link Following

Affecting bash package, versions <4.0-2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream bash package. See Remediation section below for Debian:10 relevant versions.

bash-doc 3.2 allows local users to overwrite arbitrary files via a symlink attack on a /tmp/cb#####.? temporary file, related to the (1) aliasconv.sh, (2) aliasconv.bash, and (3) cshtobash scripts.

Remediation

Upgrade Debian:10 bash to version 4.0-2 or higher.

References

CVSS Score

7.8
low severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVE
CVE-2008-5374
CWE
CWE-59
Snyk ID
SNYK-DEBIAN10-BASH-351599
Disclosed
08 Dec, 2008
Published
08 Dec, 2008