Improper Input Validation

Affecting apt package, versions <1.8.2.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Missing input validation in the ar/tar implementations of APT before version 2.1.2 could result in denial of service when processing specially crafted deb files.

References

CVSS Score

5.5
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2020-3810
CWE
CWE-20
Snyk ID
SNYK-DEBIAN10-APT-568926
Disclosed
15 May, 2020
Published
12 May, 2020