Denial of Service (DoS)

Affecting openssl package, versions >=1.0.1, <1.0.109 || >=1.0.204.1, <1.0.211

Do your applications use this vulnerable package? Test your applications

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Denial of Service (DoS). The DTLS implementation in does not properly restrict the lifetime of queue entries associated with unused out-of-order messages, which allows remote attackers to cause a denial of service (memory consumption) by maintaining many crafted DTLS sessions simultaneously, related to d1_lib.c, statem_dtls.c, statem_lib.c, and statem_srvr.c.

Remediation

Upgrade OpenSSL to version 1.0.109, 1.0.211 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Credit
Quan Luo
CVE
CVE-2016-2179
CWE
CWE-399
Snyk ID
SNYK-COCOAPODS-OPENSSL-535974
Disclosed
22 Aug, 2016
Published
27 Nov, 2019