RHSA-2016:2573

Affecting glibc package, versions <0:2.17-157.el7

Report new vulnerabilities
low severity
Do your applications use this vulnerable package? Test your applications

Overview

The glibc packages provide the standard C libraries (libc), POSIX thread libraries (libpthread), standard math libraries (libm), and the name service cache daemon (nscd) used by multiple programs on the system. Without these libraries, the Linux system cannot function correctly. Security Fix(es): * A stack overflow vulnerability was found in _nss_dns_getnetbyname_r. On systems with nsswitch configured to include "networks: dns" with a privileged or network-facing service that would attempt to resolve user-provided network names, an attacker could provide an excessively long network name, resulting in stack corruption and code execution. (CVE-2016-3075) This issue was discovered by Florian Weimer (Red Hat). Additional Changes: For detailed information on changes in this release, see the Red Hat Enterprise Linux 7.3 Release Notes linked from the References section.

CVE
RHSA-2016:2573
Snyk ID
SNYK-CENTOS7-GLIBC-356403
Published
27 Jun, 2018