ALAS2-2019-1368

Affecting python package, versions <2.7.16-4.amzn2

Report new vulnerabilities
medium severity
Do your applications use this vulnerable package? Test your applications

Overview

Package updates are available for Amazon Linux 2 that fix the following vulnerabilities: CVE-2019-16056: 99999: CVE-2019-16056 python: email.utils.parseaddr wrongly parses email addresses An issue was discovered in Python through 2.7.16, 3.x through 3.5.7, 3.6.x through 3.6.9, and 3.7.x through 3.7.4. The email module wrongly parses email addresses that contain multiple @ characters. An application that uses the email module and implements some kind of checks on the From/To headers of a message could be tricked into accepting an email address that should be denied. An attack may be the same as in CVE-2019-11340; however, this CVE applies to Python more generally.

References

CVE
ALAS2-2019-1368
Snyk ID
SNYK-AMZN2-PYTHON-535255
Published
21 Nov, 2019