ALAS2-2020-1531

Affecting libssh2 package, versions <1.4.3-12.amzn2.2.3

Report new vulnerabilities
medium severity
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to ALAS2-2020-1531. Package updates are available for Amazon Linux 2 that fix the following vulnerabilities: CVE-2019-17498: 1766898: CVE-2019-17498 libssh2: integer overflow in SSH_MSG_DISCONNECT logic in packet.c In libssh2 v1.9.0 and earlier versions, the SSH_MSG_DISCONNECT logic in packet.c has an integer overflow in a bounds check, enabling an attacker to specify an arbitrary (out-of-bounds) offset for a subsequent memory read. A crafted SSH server may be able to disclose sensitive information or cause a denial of service condition on the client system when a user connects to the server.

Remediation

Upgrade libssh2 to version or higher.

References

CVE
ALAS2-2020-1531
Snyk ID
SNYK-AMZN2-LIBSSH2-1022800
Published
28 Oct, 2020