ALAS2-2018-1135

Affecting curl package, versions <7.55.1-12.amzn2.0.7

Report new vulnerabilities
low severity
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Amzn:2 relevant versions.

Package updates are available for Amazon Linux 2 that fix the following vulnerabilities: CVE-2018-14618: 1622707: CVE-2018-14618 curl: NTLM password overflow via integer overflow curl before version 7.61.1 is vulnerable to a buffer overrun in the NTLM authentication code. The internal function Curl_ntlm_core_mk_nt_hash multiplies the length of the password by two (SUM) to figure out how large temporary storage area to allocate from the heap. The length value is then subsequently used to iterate over the password and generate output into the allocated storage buffer. On systems with a 32 bit size_t, the math to calculate SUM triggers an integer overflow when the password length exceeds 2GB (2^31 bytes). This integer overflow usually causes a very small buffer to actually get allocated instead of the intended very huge one, making the use of that buffer end up in a heap buffer overflow. (This bug is almost identical to CVE-2017-8816.)

Remediation

Upgrade Amzn:2 curl to version 7.55.1-12.amzn2.0.7 or higher.

References

CVE
ALAS2-2018-1135
Snyk ID
SNYK-AMZN2-CURL-503124
Published
13 Nov, 2019