ALAS2-2018-1029

Affecting curl package, versions <7.55.1-12.amzn2.0.1

Report new vulnerabilities
high severity
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream curl package. See Remediation section below for Amzn:2 relevant versions.

Package updates are available for Amazon Linux 2 that fix the following vulnerabilities: CVE-2018-1000301: curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl &lt; 7.20.0 and curl &gt;= 7.60.0. 1575536: CVE-2018-1000301 curl: Out-of-bounds heap read when missing RTSP headers allows information leak of denial of service CVE-2018-1000300: 1575533: CVE-2018-1000300 curl: FTP shutdown response heap-based buffer overflow can potentially lead to RCE curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl &lt; 7.54.1 and curl &gt;= 7.60.0.

Remediation

Upgrade Amzn:2 curl to version 7.55.1-12.amzn2.0.1 or higher.

References

CVE
ALAS2-2018-1029
Snyk ID
SNYK-AMZN2-CURL-496806
Published
13 Nov, 2019