Out-of-bounds Read

Affecting apk-tools package, versions <2.10.6-r0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream apk-tools package. See Remediation section below for Alpine:3.12 relevant versions.

In Alpine Linux apk-tools before 2.12.5, the tarball parser allows a buffer overflow and crash.

Remediation

Upgrade Alpine:3.12 apk-tools to version 2.10.6-r0 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2021-30139
CWE
CWE-125
Snyk ID
SNYK-ALPINE312-APKTOOLS-1246338
Disclosed
21 Apr, 2021
Published
15 Apr, 2021