Website scanner for JavaScript vulnerabilities and security headers

https://www.cdnplanet.com/

Full report

See on WebPageTest

Scan time

6/6/2020
10:34:04 PM

Webpage Security Score

A+

A+ is the best score you can get.
Learn more about this score.
Fix JavaScript vulnerabilities in your project with Snyk (or try the free & open source CLI) Test and protect my website

JavaScript Libraries with vulnerabilities

Great job! No known versions of vulnerable JavaScript libraries were detected in this website.


Monitor my web application's project dependencies

Security headers

HTTP security headers enable better browser security policies.


Successfully detected the following security headers:
Recently-discovered vulnerabilities on the Snyk database:

Date disclosed Vulnerable library Vulnerable version detected Vulnerability
2020/06/11
  • H
angular
<1.8.0 Cross-site Scripting (XSS)
2020/06/07
  • M
angular
<1.8.0 Cross-site Scripting (XSS)
2020/05/19
  • M
jquery
<1.9.0 Cross-site Scripting (XSS)
2020/05/11
  • M
buefy
<0.8.18 Cross-site Scripting (XSS)
2020/04/29
  • M
jquery
>=1.2.0 <3.5.0 Cross-site Scripting (XSS)
2020/04/28
  • M
lodash
<4.17.16 Prototype Pollution
2020/04/13
  • M
jquery
>=1.0.3 <3.5.0 Cross-site Scripting (XSS)
2019/07/02
  • H
lodash
<4.17.12 Prototype Pollution
2019/02/15
  • H
lodash
<3.4.1,>=4.0.0 <4.3.1 Cross-site Scripting (XSS)

New vulnerabilities are continuously found for jQuery, lodash, Angular and other libraries.
Monitor these libraries to protect your web application.

Stay up to date on CVEs by connecting your project to Snyk to receive automated notifications & fixes.