woocommerce-api@1.2.0

Vulnerabilities

1 via 1 paths

Dependencies

50

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

high severity

Insecure Randomness

  • Vulnerable module: crypto-js
  • Introduced through: oauth-1.0a@1.0.1

Detailed paths

  • Introduced through: woocommerce-api@1.2.0 oauth-1.0a@1.0.1 crypto-js@3.1.8
    Remediation: Upgrade to woocommerce-api@1.4.1.

Overview

crypto-js is a library of crypto standards.

Affected versions of this package are vulnerable to Insecure Randomness. The secureRandom() method is supposed to return a cryptographically strong pseudo-random data string, but it is biased to certain digits. An attacker could be able to guess the created digits.

Remediation

Upgrade crypto-js to version 4.0.0, 3.2.1 or higher.

References