tdl@5.2.0

Vulnerabilities

1 via 1 paths

Dependencies

24

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 1
Status
  • 1
  • 0
  • 0

medium severity

Remote Memory Exposure

  • Vulnerable module: node-addon-api
  • Introduced through: ffi-napi@2.5.0

Detailed paths

  • Introduced through: tdl@5.2.0 ffi-napi@2.5.0 node-addon-api@1.6.1
    Remediation: Upgrade to tdl@6.0.0.

Overview

node-addon-api is a This module contains header-only C++ wrapper classes which simplify the use of the C based N-API provided by Node.js when using C++. It provides a C++ object model and exception handling semantics with low overhead.

Affected versions of this package are vulnerable to Remote Memory Exposure via the napi_get_value_string_utf8, napi_get_value_string_latin1 and napi_get_value_string_utf16 functions.

Remediation

Upgrade node-addon-api to version 1.7.2, 2.0.1 or higher.

References