react-i18next@8.4.0

Vulnerabilities

2 via 2 paths

Dependencies

24

Source

npm

Find, fix and prevent vulnerabilities in your code.

Severity
  • 2
Status
  • 2
  • 0
  • 0

medium severity

Regular Expression Denial of Service (ReDoS)

  • Vulnerable module: html-parse-stringify2
  • Introduced through: html-parse-stringify2@2.0.1

Detailed paths

  • Introduced through: react-i18next@8.4.0 html-parse-stringify2@2.0.1

Overview

html-parse-stringify2 is a This is a fork of html-parse-stringify

Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS). Sending certain input could cause one of the regular expressions that is used for parsing to backtrack, freezing the process.

Remediation

There is no fixed version for html-parse-stringify2.

References

medium severity

Denial of Service

  • Vulnerable module: node-fetch
  • Introduced through: create-react-context@0.2.3

Detailed paths

  • Introduced through: react-i18next@8.4.0 create-react-context@0.2.3 fbjs@0.8.17 isomorphic-fetch@2.2.1 node-fetch@1.7.3
    Remediation: Upgrade to react-i18next@9.0.0.

Overview

node-fetch is an A light-weight module that brings window.fetch to node.js

Affected versions of this package are vulnerable to Denial of Service. Node Fetch did not honor the size option after following a redirect, which means that when a content size was over the limit, a FetchError would never get thrown and the process would end without failure.

Remediation

Upgrade node-fetch to version 2.6.1, 3.0.0-beta.9 or higher.

References